PAT 甲级练习 1011

1011. World Cup Betting

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W T L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.
Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output

扫描二维码关注公众号,回复: 1036279 查看本文章

T T W 37.98

这里例子有误,输出应为37.97,不需要四舍五入

代码如下:

#include <iostream>
#include <vector>
#include <iomanip>

using namespace std;

int main()
{
    char hd[3] = {'W', 'T', 'L'};
    vector<char> table_hd(hd, hd+3);
    vector<vector<double> > record(3, vector<double>(3, 0.0));
    //read
    double db;
    for(int i=0; i<3; ++i){
        for(int j=0; j<3; ++j){
            cin >> db;
            record[i][j] = db;
        }
    }
    //find max number of each line
    int index;
    vector<int> result_idx(3);
    double val, mul_val = 1;
    for(int r=0; r<3; ++r){ //for each line
        index = 0, val = 0;
        for(int c=0; c<3; ++c) //for each element
            if(record[r][c] > val)
                index = c, val = record[r][c];
        result_idx[r] = index;
        mul_val *= val;
    }
    //print
    for(int i=0; i<3; ++i)
        cout << table_hd[result_idx[i]] << ' ';
    cout << setprecision(2) << fixed << (mul_val*0.65 - 1)*2 + 0.005 << endl;

    return 0;
}

注意:本题示例有误,添加四舍五入后反而ac不了。

猜你喜欢

转载自blog.csdn.net/linlinlin96/article/details/79480618