中油5577: Mysterious Light

5577: Mysterious Light

时间限制: 2 Sec   内存限制: 256 MB
提交: 248   解决: 77
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

Snuke is conducting an optical experiment using mirrors and his new invention, the rifle of Mysterious Light.

Three mirrors of length N are set so that they form an equilateral triangle. Let the vertices of the triangle be a,b and c.

Inside the triangle, the rifle is placed at the point p on segment ab such that ap=X. (The size of the rifle is negligible.) Now, the rifle is about to fire a ray of Mysterious Light in the direction of bc.

The ray of Mysterious Light will travel in a straight line, and will be reflected by mirrors, in the same ways as "ordinary" light. There is one major difference, though: it will be also reflected by its own trajectory as if it is a mirror! When the ray comes back to the rifle, the ray will be absorbed.

The following image shows the ray's trajectory where N=5 and X=2.
It can be shown that the ray eventually comes back to the rifle and is absorbed, regardless of the values of N and X. Find the total length of the ray's trajectory.

Constraints
2≦N≦1012
1≦X≦N−1
N and X are integers.
Partial Points
300 points will be awarded for passing the test set satisfying N≦1000.
Another 200 points will be awarded for passing the test set without additional constraints.

输入

The input is given from Standard Input in the following format:N X

输出

Print the total length of the ray's trajectory.

样例输入

5 2

样例输出

12

提示

Refer to the image in the Problem Statement section. The total length of the trajectory is 2+3+2+2+1+1+1=12.

来源

AtCoder Grand Contest 001 



#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;


int main()
{
    long long n,x;
    scanf("%lld%lld",&n,&x);
    if(x>n/2) x=n-x;///x表示折射长度
    long long tmp=n-x;///tmp表示折射区间
    long long zhong;
    long long ans=0;
    while(x!=0)
    {
        ans+=(tmp/x)*x*3;///tmp/x表示有几个三角形
        zhong=tmp%x;///表示下一组生成的三角形的长度
        tmp=x;
        x=zhong;
    }
    printf("%lld\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wonder__/article/details/79855857