Mysterious Light

 Mysterious Light

题目描述

Snuke is conducting an optical experiment using mirrors and his new invention, the rifle of Mysterious Light.

Three mirrors of length N are set so that they form an equilateral triangle. Let the vertices of the triangle be a,b and c.

Inside the triangle, the rifle is placed at the point p on segment ab such that ap=X. (The size of the rifle is negligible.) Now, the rifle is about to fire a ray of Mysterious Light in the direction of bc.

The ray of Mysterious Light will travel in a straight line, and will be reflected by mirrors, in the same ways as "ordinary" light. There is one major difference, though: it will be also reflected by its own trajectory as if it is a mirror! When the ray comes back to the rifle, the ray will be absorbed.

The following image shows the ray's trajectory where N=5 and X=2.
It can be shown that the ray eventually comes back to the rifle and is absorbed, regardless of the values of N and X. Find the total length of the ray's trajectory.

Constraints
2≦N≦1012
1≦X≦N−1
N and X are integers.
Partial Points
300 points will be awarded for passing the test set satisfying N≦1000.
Another 200 points will be awarded for passing the test set without additional constraints.

输入

The input is given from Standard Input in the following format:N X

输出

Print the total length of the ray's trajectory.

样例输入

5 2

样例输出

12

提示

Refer to the image in the Problem Statement section. The total length of the trajectory is 2+3+2+2+1+1+1=12.


我当时做题是用while模拟的过程。之后看了题解才知道有规律。

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string.h>
#include<cmath>
typedef long long ll;
using namespace std;
  
int main (){
    ll n,x;
    ll count1,temp,sum,tt,a,b,p;
    scanf("%lld%lld",&n,&x);
    sum=n;a=n-x;b=x;
    if(n-x==x){
        printf("%lld\n",x*3);
        return 0;
    }
    else if(n-x<=x)
        swap(a,b);
    count1=a/b;
    temp=b;
    tt=a;
    while(tt%temp){
        sum+=count1*2*temp;
        p=tt;
        tt=temp;
        temp=p-temp*count1;
        count1=tt/temp;
    }
    printf("%lld\n",sum+count1*2*temp-temp);
    return 0;
}
 
#include<bits/stdc++.h>
typedef long long ll;
using namespace std;
int main (){
    ll n,x;
    scanf("%lld%lld",&n,&x);
    printf("%lld\n",3*(n-__gcd(n,x)));
    return 0;
}


猜你喜欢

转载自blog.csdn.net/sxh759151483/article/details/79857802