Light Bulb

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000
#include<bits/stdc++.h>
using namespace std;

int main()
{
    double t1,t2,D,H,max,h;
    int n;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%lf %lf %lf",&H,&h,&D);
        t1=D-(h*D/H);
        t2=sqrt((H-h)*D);
        if(t1<=t2&&t2<=D)
            max=D+H-2*sqrt((H-h)*D);
        else if(t1>t2)
            max=h*D/H;
        else
            max=h;
        printf("%.3f\n",max);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Y_yunhu/article/details/82047858