PAT (Advanced Level) Practice 1011 World Cup Betting (20)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output

T T W 37.98

C++:

#include<cstdio>
float max(float a,float b,float c){
	return (a>b?a:b) > c ? (a>b?a:b) : c;
}

int main(){
	char title[3]={'W','T','L'};
	char ans[3];
	float a,b,c;
	float money=1.0;
	for(int i=0;i<3;i++){
		scanf("%f%f%f",&a,&b,&c);
		money *= max(a,b,c);
		if(max(a,b,c)==a)
			ans[i]=title[0];
		else if(max(a,b,c)==b)
			ans[i]=title[1];
		else
			ans[i]=title[2];
	}
	
	money= (money*0.65-1)*2;	
	printf("%c %c %c %.2f",ans[0],ans[1],ans[2],money);	
	
	return 0;
}

注:

此题最大的注意点就是浮点数,还有叠乘的初值不能设为0!

猜你喜欢

转载自blog.csdn.net/lili_code/article/details/80628996
今日推荐