A Simple Triangle

版权声明:《本文为博主原创文章,转载请注明出处。 》 https://blog.csdn.net/zbq_tt5/article/details/88900706

In this problem you need to make a triangle ,just like the sample out. The element in the ith row and jth column

should be the product(乘积) of i and j.

Input

The first line of input is an integer C which indicate the number of test cases. 
Then C test cases follow.Each test case contains an integer N (1<=N<=20) in a line which mentioned above.

Output

For each test case, print out the triangle. the triangle separated by a blank line. 
If the product is more than 9 (product > 9) you should print a space, or you should print two space.The final number of each line don't need print space. 

Sample Input

3
5
6
7

Sample Output

1  2  3  4  5
2  4  6  8
3  6  9
4  8
5

1  2  3  4  5  6
2  4  6  8  10
3  6  9  12
4  8  12
5  10
6

1  2  3  4  5  6  7
2  4  6  8  10 12
3  6  9  12 15
4  8  12 16
5  10 15
6  12
7

题意:给出一个数,输出相应的数据

题解:直接两层for循环就行了,关键就是在输出的时候要注意格式

           If the product is more than 9 (product > 9) you should print a space, or you should print two space

那么在输出的时候,要考虑三种情况:

1、是否为最后一个数据

2、是否大于9

3、是否小于9

#include<stdio.h>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<vector>
#include<map>
#include<iostream>
using namespace std;

int main()
{
    int n;
    cin>>n;
    for(int kk=0;kk<n;++kk)
    {
        int num;
        cin>>num;
        for(int i=1;i<=num;++i)
        {
            for(int j=1;j<=num-i+1;++j)
            {
                if(j!=num-i+1)
                {
                    if(i*j<=9)
                        printf("%d  ",i*j);
                    else
                        printf("%d ",i*j);
                }
                else
                printf("%d",i*j);
            }
            printf("\n");
        }
        if(kk!=n-1)
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zbq_tt5/article/details/88900706