7-9 输出GPLT (20 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_39427510/article/details/82925467

软件学院第十四次训练


205 分

  1. 编程题共 9 小题,共计 205 分

剩余时间: 694:28:31

剩余时间: 694:28:31

7-9 输出GPLT (20 分)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL
#include<iostream>
#include<cstring>
using namespace std;
char a[10005];
int b[4];//分别存储GPLT的个数 
int main(){
cin>>a;
for(int i=0;i<strlen(a);i++){
	if(a[i]=='G'||a[i]=='g') b[0]++;
	else if(a[i]=='P'||a[i]=='p') b[1]++;
	else if(a[i]=='L'||a[i]=='l') b[2]++;
	else if(a[i]=='T'||a[i]=='t') b[3]++;
}
while(1){
	if(b[0]!=0){ cout<<'G';b[0]--;}
	 if(b[1]!=0){ cout<<'P';b[1]--;}
	 if(b[2]!=0){ cout<<'L';b[2]--;}
	 if(b[3]!=0){ cout<<'T';b[3]--;}
	 if(b[0]==0&&b[1]==0&&b[2]==0&&b[3]==0) break;
}
cout<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39427510/article/details/82925467