L1-023 输出GPLT (20 分)

L1-023 输出GPLT (20 分)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

模拟。。。

#include<bits/stdc++.h>
using namespace std;
string s;
const int M = 10000+100;
int num[M];
int p[5];
char ss[5]={'0','G','P','L','T'};
int main()
{
	cin >> s;
	int l = s.length();
	for(int i =0;i<l;i++)
		num[s[i]-'A']++;
	p[1]=num['g'-'A']+num['G'-'A'];
	p[2]=num['p'-'A']+num['P'-'A'];
	p[3]=num['l'-'A']+num['L'-'A'];
	p[4]=num['t'-'A']+num['T'-'A'];
	bool flag=false;
	while(1)
	{
		if(flag)
		break;
		flag=true;	
		for(int i=1;i<=4;i++)
			if(p[i]>0)
				printf("%c",ss[i]),flag=false,p[i]--;
	}
	puts("");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/bjfu170203101/article/details/88831964