7-4 输出GPLT(20 分)

7-4 输出GPLT(20 分)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int main()
{
    int g=0,p=0,l=0,t=0;
    string str;
    getline(cin,str);
    int len = str.length();
    for(int i=0;i<len;i++)
    {
        if(str[i]=='G'||str[i]=='g')
            g++;
        if(str[i]=='P'||str[i]=='p')
            p++;
        if(str[i]=='L'||str[i]=='l')
            l++;
        if(str[i]=='T'||str[i]=='t')
            t++;
    }
    while(g!=0||p!=0||l!=0||t!=0)
    {
        if(g)
        {
            cout<<"G";
            g--;
        }
        if(p)
        {
            cout<<"P";
            p--;
        }
        if(l)
        {
            cout<<"L";
            l--;
        }
        if(t)
        {
            cout<<"T";
            t--;
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_40099908/article/details/81665495
今日推荐