HDU 4738 割边

Caocao's Bridges

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8322    Accepted Submission(s): 2557


Problem Description
Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.
 
Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.
 
Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.
 
Sample Input
3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0
 
Sample Output
-1
4
 

 解析 无向图求割边,输出权值最下的割边的边权,不连通直接为0,权值等于0,则至少派一个人去炸桥,输出1

AC代码

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

const int maxn = 1e5 + 10,inf = 0x3f3f3f3f;

struct node
{
    int v, w, next;
} edge[maxn << 2];

int bridge[maxn];
int low[maxn], dfn[maxn], vis[maxn];
int head[maxn],tot, sol, num;

void init(void)
{
    memset(head, -1, sizeof(head));
    memset(dfn, 0, sizeof(dfn));
    memset(bridge, 0, sizeof(bridge));
    num = sol = tot = 0;
}

void addedge(int u, int v,int w)
{
    edge[tot].v = v;
    edge[tot].w = w;
    edge[tot].next = head[u];
    head[u] = tot++;
}

void tarjan(int u,int fa)
{
    dfn[u] = low[u] = ++num;
    int pre_num=0;
    for(int i = head[u]; i != -1; i = edge[i].next)
    {
        int v = edge[i].v;
        if(v==fa&&pre_num==0)
        {
            pre_num++;
            continue;
        }
        if(!dfn[v])
        {
            tarjan(v,u);
            low[u] = min(low[u], low[v]);
            if(dfn[u] < low[v])
            {
                bridge[sol++]=edge[i].w;
            }
        }
        else
        {
            low[u] = min(low[u], dfn[v]);
        }
    }
}

int main()
{
    int n, m, x, y, z;
    while(~scanf("%d%d", &n, &m))
    {
        if(!n && !m)
            break;
        init();
        for(int i = 0; i < m; i++)
        {
            scanf("%d%d%d", &x, &y, &z);
            addedge(x, y, z);
            addedge(y, x, z);
        }
        tarjan(1,1);
        int flag=0;
        for(int i=1; i<=n; i++)
            if(!dfn[i])
            {
                flag=1;
                break;
            }
        if(flag)
        {
            printf("0\n");
            continue;
        }
        int minn=inf;
        for(int i=0; i<sol; i++)
            minn=min(minn,bridge[i]);
        if(minn==0)minn++;
        if(minn==inf)
            printf("-1\n");
        else
            printf("%d\n",minn);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/stranger-/p/10050799.html