【ACM】POJ 3069

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/CSDN___CSDN/article/details/84639450

【问题描述】

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

【输入描述】

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xnof each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

【输出描述】

For each test case, print a single integer indicating the minimum number of palantirs needed.

【样例输入】

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

【样例输出】

2
4

题目大致意思是给定一个半径R,然后为了让一个以半径为R的圆内尽可能地包括多的点,需要多少个圆

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1100;
int a[maxn];
int main ()
{
	int R,n,i,j,count,m,x;
	while(scanf("%d%d",&R,&n)!=EOF)
	{
		if(R==-1 && n==-1)	return 0;
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		sort(a,a+n);
		i=0;count=0;
		while(i<n)
		{
			x=a[i];
			while(i<n && a[i]<=R+x)
				i++;
			m=a[i-1];
			while(i<n && a[i]<=R+m)
				i++;
			count++;
		}
		printf("%d\n",count);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/CSDN___CSDN/article/details/84639450
今日推荐