POJ-3069 Saruman's Army(贪心)

Saruman's Army

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14056   Accepted: 7053

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source

Stanford Local 2006

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
#define MAXN 1010
int a[MAXN];
int main()
{
   int n,r;
   while(scanf("%d%d",&r,&n),r!=-1&&n!=-1)
  {
    int i,ans=0;
    for(i=1;i<=n;i++)
    scanf("%d",&a[i]);
    sort(a+1,a+n+1);
    i=1;
    while(i<=n)
    {
      int s=a[i++];
      //一直向右前进直到距s的距离大于r的点
      while(i<=n&&a[i]<=s+r) //退出这个循环的a[i]一定是不满足条件的a[i];
      i++;
      //p是新标记的点的位置
      int p=a[i-1];
      //一直向右前进直到距p的距离大于r的点
      while(i<=n&&a[i]<=p+r)
      i++;
      ans++;          //每次找两个点才记一次答案,也很好理解
     }
     printf("%d\n",ans);
  }
   return 0;
}

猜你喜欢

转载自blog.csdn.net/xigongdali/article/details/81448232