Saruman's Army - poj3069 - 贪心

Saruman's Army

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13965   Accepted: 7006

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source

Stanford Local 2006

思路:

循环以下两步:

1、找到最左侧的点

2、根据最左侧的点来添加标记点(下图红色点为标记点)

找到能覆盖最左边点的最靠右的点,把它标记,然后从标记点向后寻找r范围内的点,直到r不能覆盖该点,此时,该点变成了新的最左边的点

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
 
using namespace std;

int a[1005];

int main(){
	int r,n;
	while(scanf("%d%d",&r,&n)!=EOF){
		if(r==-1&&n==-1)break;
		for(int i=0;i<n;i++){
		    scanf("%d",&a[i]);
	    }
	    sort(a,a+n);
	    if(a[n-1]<=r){printf("1\n");continue;}
	    int ans=0,i=0;
	    while(i<n){
	    	int s=a[i++];
	    	while(i<n&&a[i]-s<=r)i++;
	    	int p=a[i-1];
	    	while(i<n&&a[i]-p<=r)i++;
	    	ans++;
		}
		printf("%d\n",ans);
	}
}

猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/81271562