POJ-3069 Saruman's Army

题目描述:

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

输入:

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xnof each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

输出:

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1
Sample Output
2
4
Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题意:在一直线上有若干个点,和一个数r,求最小的点的个数,使得这些点可以覆盖给出的所有点,其中这些点必须是在给出的这些点里,而且他们的覆盖范围是r。

解题思路:主要就是找出所有的中心位置,使得这些点可以覆盖所有的点,这里我们可以这样考虑,从第一个点a[0]开始往后找,找出所有的在r范围内的点,然后等价于最后的这个点a[i]是可以覆盖到a[0]的,然后再从a[i]开始往后找,找出所有的据a[i]小于r的点,这时候,a[i]就是满足要求的点,然后再从a[i+1]开始重复这个过程,就可以找出所有满足要求的点的个数,也是最少的点的个数。

AC代码:

#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
int r, n;
const int maxn = 1000 + 10;
int a[maxn];
int ans = 0;
int main()
{
	cin >> r >> n;
	while (r != -1 && n != -1)
	{
		for (int i = 0; i < n; i++)
		{
			cin >> a[i];
		}
		sort(a, a + n);
		ans = 0;
		int k, t = 0;
		for (int i = 0,j; i < n;)
		{
			k = a[i];
			for (j = i+1; j < n;)
			{
				if (r + k >= a[j]) j++;
				else break;
			}
			i = j - 1;
			t = a[i];
			for (j = i + 1; j < n;)
			{
				if (r + t >= a[j]) j++;
				else break;
			}
			i = j;
			ans++;
		}
		cout << ans << endl;
		cin >> r >> n;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40129237/article/details/80285945