POJ3069 Saruman's Army

题目链接:POJ3069 Saruman’s Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20492 Accepted: 9926

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

程序说明:

贪心算法,先把坐标位置从小到大排序,从第一个点开始,找出该点右侧距离不超过R的最远的点,并标记,再从此标记点处的右侧找距离超过R的第一个的点作为下一次循环的起始点。

代码如下:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int MAX = 1001;
int r, n;
int s[MAX];
int main() {
	while(scanf("%d%d", &r, &n) && r != -1 && n != -1) {
		int cnt = 0;
		for(int i = 0; i < n; i++)
			scanf("%d", &s[i]);
		//坐标从小到大排序 
		sort(s, s + n);
		int i = 0;
		while(i < n) {
			//记录起始点 
			int k = s[i];
			//找到起始点距离超过R的第一个点的坐标
			while(i < n && s[i] <= k + r)
				i++;
			//前一个点就是距离不超过R的最远的点并标记 
			int p = s[i - 1];
			//找到被标记点距离超过R的第一个点的坐标,即
			//下一次循环的起始点
			while(i < n && s[i] <= p + r)
				i++;
			cnt++;
		}
		printf("%d\n", cnt);
	}
	return 0;
} 
发布了44 篇原创文章 · 获赞 0 · 访问量 838

猜你喜欢

转载自blog.csdn.net/Komatsu_1137/article/details/104068006