Til the Cows Come Home (dijkstra算法)

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

题解:这个基本是可以套用dijkstra算法,并且需要注意双向赋值,别的基本没什么坑点

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>

using namespace std;

const int Inf = 0x3f3f3f3f ;
const int MAXN = 2005;
int dis[MAXN];
int map[MAXN][MAXN];//用来存储图 
bool vis[MAXN];//用来标记,避免重复搜 
int n,m ;//n个点,m条边 
// u 为单源点 
void dijkstra(int u)//dijkstra的算法 
{
    int t = u;
    dis[t] = 0 ;
    vis[t] = true ;
    for ( int i = 1 ; i <= n ; i ++ )
	{
        for ( int j = 1 ; j <= n ; j ++ )
		{
            if ( !vis[j] && map[t][j] + dis[t] < dis[j] )//判断直接近,还是间接近 
			{
                dis[j] = map[t][j] + dis[t] ;
            }
        }
        int mini = Inf ;
        for ( int j = 1 ; j <= n ; j ++ )
		{
            if ( !vis[j] && dis[j] < mini )
			{ 
				mini = dis[j] ;
				t=j;
            }
        }
        
		vis[t] = true ;
    }
}

void init()
{
    memset(vis,false,sizeof(vis)) ; //初始化标记数组 
    for ( int i = 1 ; i <= n ; i ++ )
	{
        dis[i] = Inf ;
        for ( int j = 1 ; j <= n ; j ++ )
		{
            map[i][j] = Inf ;
        }
    }
    return ;
}

int main()
{
    while (scanf("%d%d",&m,&n)!=EOF)
	{
        init();
        memset(map,Inf,sizeof(map));//初始化图 
        for ( int i = 0 ; i < m ; i ++ )
		{
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);//表示 u 到 v的距离为 w 
            if ( map[u][v] > w )
			{
                map[v][u] = map[u][v] = w ;
            }
        }
        dijkstra(1);
        cout<<dis[n]<< endl ;
    }
    return 0 ;
}

猜你喜欢

转载自blog.csdn.net/lbperfect123/article/details/84261974
今日推荐