POJ 2387 A - Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

题目的意思就是求从1到n的最短距离。

很简单的一个最短路题目。

用的是邻接表加上迪杰斯特拉算法。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include <iostream>
using namespace std;
const int maxn=10005;
const int INF=0x3f3f3f3f;
struct edge
{
    int len;
    int fin;
    edge *next;
};
struct city
{
    edge * e;
};
city c[maxn];
int vis[maxn];
int d[maxn];
int t,n;
void djsi ()
{
    edge * temp;
    d[1]=0;
    while (1)
    {
        int u=-1;
        int maxx=INF;
        //将到顶点最小距离的且没被访问过的拿出来;
        for (int i=1;i<=n;i++)
        {
            if(!vis[i]&&d[i]<maxx)
            {
                u=i;
                maxx=d[i];
                //printf("::: %d\n",u);
            }
        }
        if(u==-1)
            break;
        else
            {
                temp=c[u].e;
                vis[u]=1;
            }
        //如果此时1到temp->fin的距离比1到u的距离加上u到temp->fin的距离小,那么更新d[temp->fin];
        while (temp)
        {
            if(!vis[temp->fin])
            {
                if(d[temp->fin]>d[u]+temp->len)
                     d[temp->fin]=d[u]+temp->len;
            }
            temp=temp->next;
        }
    }
}
int main()
{
    memset (vis,0,sizeof(vis));
    scanf("%d%d",&t,&n);
    int tempp=t;
    for (int i=0;i<=maxn;i++)
          {
              c[i].e=NULL;
              d[i]=INF;
          }
    for (int i=0;i<tempp;i++)
    {
        int x,y,len;
        scanf("%d%d%d",&x,&y,&len);
        edge *e1=(edge *)malloc(sizeof(edge));
        edge *e2=(edge *)malloc(sizeof(edge));
        e1->fin=y;
        e1->len=len;
        e1->next=c[x].e;
        c[x].e=e1;
        e2->fin=x;
        e2->len=len;
        e2->next=c[y].e;
        c[y].e=e2;
    }
    djsi ();
    printf("%d\n",d[n]);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/81410792
今日推荐