Til the Cows Come Home//POJ - 2387//dijkstra

Til the Cows Come Home//POJ - 2387//dijkstra


题目

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input

  • Line 1: Two integers: T and N

  • Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.
    Output

  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100
    Sample Output
    90
    题意
    给了所有路径,求1-n最短路径
    链接:https://vjudge.net/contest/351234#problem/L

思路

dijkstra算法模板题,单源最短路径

代码

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#define maxn 0x3fffffff
int mp[1005][1005];//邻接表
int dis[1005];     //起点到该点最短距离

void dijkstra(int n){
    int vis[1001]={0};
    int minn,i,j,temp;
    vis[1]=1;
    for(i=1;i<n;++i){
        minn=maxn;
        temp=1;
        for(j=1;j<=n;++j){                 //寻找最小值
            if(!vis[j]&&minn>dis[j]){      //未访问过
                minn=dis[j];
                temp=j;
            }
        }
        vis[temp]=1;                          //最小值处改为已访问
        for(j=1;j<=n;++j){                      //计算该新加入的数周围的点的距离
            if(!vis[j]&&dis[j]>dis[temp]+mp[temp][j])
                dis[j]=dis[temp]+mp[temp][j];
        }
    }
    return;
}
int main(){
    int t,n,from,to,cost;
    while(scanf("%d%d",&t,&n)!=EOF){
        for(int i=1;i<=n;++i){
            mp[i][i]=0;
            for(int j=1;j<i;++j)
                mp[i][j]=mp[j][i]=maxn;                  //初始化数组
        }
        for(int i=1;i<=t;++i){
            scanf("%d%d%d",&from,&to,&cost);
            if(cost<mp[from][to])                        //记录最短的路径
                mp[from][to]=mp[to][from]=cost;
        }
        for(int i=1;i<=n;++i)
            dis[i]=mp[1][i];
        dijkstra(n);
        printf("%d\n",dis[n]);
    }
    return 0;
}

注意

多组输入输出

发布了24 篇原创文章 · 获赞 9 · 访问量 530

猜你喜欢

转载自blog.csdn.net/salty_fishman/article/details/103992982