//并查集//poj1611//The Suspects------四L

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

解题思路:
在普通并查集模板上,加入一个数组sum,记录每个父结点的人数。
最后只要找到0的父结点,输出此父结点的人数就可以了。
要注意father[a]=b时,b是a的父结点,所以应该sum[b]+=sum[a]。

#include<stdio.h>

int stu,gro,k;
int in[30005],father[30005],sum[30005];

void init()
{
    for(int i=0;i<stu;i++)
    {
        father[i]=-1;
        sum[i]=1;
    }
}

int find(int m)
{
    if(father[m]==-1)
        return m;
    else
    {
        father[m]=find(father[m]);
        return father[m];
    }
}

void Union(int x,int y)
{
    int a=find(x);
    int b=find(y);
    if(a!=b)
    {
        father[a]=b;
        sum[b]+=sum[a];
    }
}

int main()
{
    while(1)
    {
        scanf("%d%d",&stu,&gro);
        if(stu==0&&gro==0) return 0;
        init();
        for(int i=1;i<=gro;i++)
        {
            scanf("%d",&k);
            for(int j=1;j<=k;j++)
            {
                scanf("%d",&in[j]);
                if(j>1)
                    Union(in[j-1],in[j]);
            }
        }

        printf("%d\n",sum[find(0)]);
    }
}

猜你喜欢

转载自blog.csdn.net/lydia_ke/article/details/79343450