PTA List Sorting (25分)

释放无限光明的是人心,制造无边黑暗的也是人心,光明和黑暗交织着,厮杀着,这就是我们为之眷恋又万般无奈的人世间。

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and Cis the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
#include<bits/stdc++.h>
using namespace std;
struct node{
    char id[7];
    char name[10];
    int cj;
};
bool cmp1(node a,node b){
    return strcmp(a.id,b.id)<0;
}
bool cmp2(node a,node b){
    if(strcmp(a.name,b.name)!=0)
        return strcmp(a.name,b.name)<0;
    else
        return strcmp(a.id,b.id)<0;
}
bool cmp3(node a,node b){
    if(a.cj!=b.cj)
        return a.cj<b.cj;
    else
        return strcmp(a.id,b.id)<0;
}
int main()
{
    int n,c,cj;
    char id[7],name[10];
    cin>>n>>c;
    vector<node> stu(n);
    for(int i=0;i<n;i++)
        scanf("%s %s %d",&stu[i].id,&stu[i].name,&stu[i].cj);
    if(c==1)
        sort(stu.begin(),stu.end(),cmp1);
    else if(c==2)
        sort(stu.begin(),stu.end(),cmp2);
    else
        sort(stu.begin(),stu.end(),cmp3);
    for(int i=0;i<n;i++)
        printf("%s %s %d\n",stu[i].id,stu[i].name,stu[i].cj);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44170305/article/details/108558537