HDU1087 Super Jumping! Jumping! Jumping!【最长递增子序列】

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51350    Accepted Submission(s): 23836


 

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

Author

lcy

问题链接:HDU1087 Super Jumping! Jumping! Jumping!

问题描述:由N个正整数组成的序列,问最长递增子序列之和的最大值(严格递增)

解题思路:dp[i]表示以i结尾的递增序列的最大和 ,dp[i]=dp[j]+a[i]。其中dp[j]是 [0,i)区间中小于第i个数的数中dp值的最大值

AC的C++代码:

#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;

const int N=1005;
int a[N];
int dp[N];//dp[i]表示以i结尾的递增序列的最大和 

int main()
{
	int n;
	while(scanf("%d",&n)&&n){
		for(int i=0;i<n;i++)
		  scanf("%d",&a[i]);
		dp[0]=a[0];
		for(int i=1;i<n;i++){
			//选择[0,i)这个区间小于a[i]的元素中dp的最大值 
			int temp=0; 
			for(int j=0;j<i;j++)
			  if(a[j]<a[i])
			    temp=max(temp,dp[j]);
			dp[i]=temp+a[i]; 
		}
		int ans=0;
		for(int i=0;i<n;i++)
		  ans=max(ans,dp[i]);
		printf("%d\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/83869904