HDU 2058 The sum problem——————数学

版权声明:转载请注明出处 https://blog.csdn.net/Hpuer_Random/article/details/83154772

The sum problem

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31416 Accepted Submission(s): 9409


Problem Description

Given a sequence 1,2,3,…N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.


Input

Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output

For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.


Sample Input

20 10
50 30
0 0

Sample Output

[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]


这道题的答案可以根据等差数列的性质得到:
最大的区间长度 :
1 + 2 + 3 + + 2 m &gt; m \large \sqrt{1+2+3+\cdots+2m}&gt; m
l m a x = 2 × m \large l_{max} =\sqrt{2\times m}

由等差数列
S n = ( a 1 + a n ) × n 2 \Large S_n = \frac{(a_1 + a_n)\times n}{2}
S n = ( a 1 + a 1 + d ( n 1 ) ) × n 2 \Large S_n = \frac{(a_1 + a_1+d*(n-1))\times n}{2}
S n = ( 2 a 1 + d ( n 1 ) ) × n 2 \Large S_n = \frac{(2*a_1+d*(n-1))\times n}{2}

又因为d=1,故:
S n = ( 2 a 1 + n 1 ) × n 2 \Large S_n = \frac{(2*a_1+n-1)\times n}{2}
a 1 = S n n n 1 2 \Large a_1 = \frac{S_n}{n}-\frac{n-1}{2}
那么
a n = a 1 + n 1 \Large a_n = a_1 + n-1

对于这一道题:m就相当于Sn,
假设 &ThickSpace; m = ( a i + a j ) × ( j i + 1 ) 2 \;\Large m = \frac{(a_i+a_j)\times (j-i+1)}{2}
我们可以枚举 a i a_i
因为我们知道最大的区间长度为 l m a x = 2 × m \large l_{max} =\sqrt{2\times m}
所以枚举 1 l 1到l 的所有值
那么根据上边的可以得到
a 1 = m l l 1 2 \Large a_1 = \frac{m}{l}-\frac{l-1}{2}
a n = a 1 + n 1 \Large a_n = a_1 + n-1
只要 ( a 1 + a 2 ) l 2 = = m (a_1+a_2)*\frac{l}{2} == m
就好了

代码很短,就这几行:


#include<bits/stdc++.h>
using namespace std;
int main()
{
        int n,m;
        while(~scanf("%d %d",&n,&m)&&(n|m))
        {
                int l=sqrt(2*m);//最大区间长度为 L
                int a1,an;
                for(int k=l;k>0;--k)//区间长度为k
                {
                        a1 = m/k-(k-1)/2;
                        an = a1 + k-1;
                        if((a1 + an )*k/2 == m)
                                printf("[%d,%d]\n",a1,an);
                }
                printf("\n");
        }
        return 0;
}

猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/83154772