HDU - 2058 The sum problem

Description

Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

Input

Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output

For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

Sample Input

20 10
50 30
0 0

Sample Output

[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]
#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;

int main()
{
    int n, m, a;

    while (scanf("%d %d", &n, &m) != EOF)
    {
        if (n==0 && m==0)
            break;
        int len = (int)sqrt(2*m);
        while (len--)
        {
            a = m / (len+1) - len / 2;
            if ((2*a+len)*(len+1)/2 == m)
                printf("[%d,%d]\n", a, a+len);
        }
        printf("\n");
    }

    return 0;
}
发布了329 篇原创文章 · 获赞 342 · 访问量 17万+

猜你喜欢

转载自blog.csdn.net/Aibiabcheng/article/details/105337369
今日推荐