PAT甲级 1079 Total Sales of Supply Chain (25 分)DFS

参考链接:https://www.cnblogs.com/grglym/p/7922417.html

1079 Total Sales of Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K​i​​ ID[1] ID[2] ... ID[K​i​​]

where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. K​j​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10​10​​.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

题目大意:给一棵树,在树根出货物的价格为p,然后从根结点开始每往下走一层,该层的货物价格将会在父亲结点的价格上增加r%,给出每个叶结点的货物量,求他们的价格之和

解法: 该题是计算树的层数,所以可以用DFS、BFS都可,这里选用DFS即可轻松解决,注意pow()函数的用法

#include <cstdio>
#include <cmath>
#include <vector>
using namespace std;

vector<vector<int>> e;
vector<int> w;
int n;
double p,r,res = 0;

void dfs(int v,int lno){
	if(e[v].size() == 0){
		res += w[v] * pow(1+r/100,lno) * p;
		return;
	}
	for(int i=0;i<e[v].size();i++)
		dfs(e[v][i],lno+1);
}

int main(){
	scanf("%d %lf %lf",&n,&p,&r);
	e.resize(n);
	w.resize(n);
	
	int k,num;
	double weight;
	for(int i=0;i<n;i++){
		scanf("%d",&k);
		if(k == 0){
			scanf("%lf",&weight);
			w[i] = weight;
		}else{
			for(int j=0;j<k;j++)
			{	
				scanf("%d",&num);
				e[i].push_back(num);
			}
		}	
	}
	dfs(0,0);
	printf("%.1f",res);
	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/83098120