PAT 1079 Total Sales of Supply Chain (25 分)

1079 Total Sales of Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.
Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.
Now given a supply chain, you are supposed to tell the total sales from all the retailers.


Input Specification:
Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤ 1 0 5 10^5 ), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K i K_i ID[1] ID[2] … ID[ K i K_i ]
where in the i-th line, K i K_​i is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K j K_j being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K j K_j . All the numbers in a line are separated by a space.


Output Specification:
For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1 0 10 10^{10} .

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4




解析


这题的输入样例就是上图。其实是树的遍历。用DFS或BFS都可以。我用的BFS
树的实现就用静态实现就挺好PAT && 树

#include<algorithm>
#include<cstdio>
#include<iostream>
#include<queue>
#include<string>
#include<cmath>
using namespace std;
const int maxn = 100001;
struct node {
	int layer,carry;
	vector<int> child;
	node() :layer(0),carry(0) { ; }
}Node[maxn];
double layerorder(double p,double r) {
	double sum = 0.0;
	queue<int> q;
	q.push(0);
	Node[0].layer = 1;
	while (!q.empty()) {
		int temp = q.front();
		if (Node[temp].carry != 0)
			sum += Node[temp].carry*pow(1 + r, Node[temp].layer-1)*p;
		q.pop();
		for (int i = 0; i < Node[temp].child.size(); i++) {
			q.push(Node[temp].child[i]);
			Node[Node[temp].child[i]].layer = Node[temp].layer + 1;
		}
	}
	return sum;
}
int main()
{
	int N,K;
	double P, r;
	scanf("%d %lf %lf",&N, &P, &r);
	for (int i = 0; i < N; i++) {
		scanf("%d", &K);
		if (K == 0) 
			scanf("%d", &Node[i].carry);
		else {
			int son;
			for (int j = 0; j < K; j++) {
				scanf("%d", &son);
				Node[i].child.push_back(son);
			}
		}
	}
	double sum = layerorder(P,r*0.01);
	printf("%.1f", sum);
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/84307976