1079 Total Sales of Supply Chain (25)(25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=10^5^), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K~i~ ID[1] ID[2] ... ID[K~i~]

where in the i-th line, K~i~ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. K~j~ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K~j~. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10^10^.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

扫描二维码关注公众号,回复: 2730699 查看本文章
42.4

注意一点:计算叶子节点的次方时用#incllude<cmath>下的pow函数,不然最后一个样例会超时

#include <iostream>
#include <stack>
#include <queue>
#include <vector>
#include <stdio.h>
#include <math.h>
using namespace std;
const int maxn = 11e5;
struct Node
{
    vector<int> child;
    int layer;
} node[maxn];
int ment[maxn];
int main()
{
    for(int i=0; i<maxn; i++)
        ment[i] = 0;
    int n;
    double price,rate;
    cin>>n>>price>>rate;
    rate = rate / 100;
    int root = 0;
    int num,x;
    for(int i=0; i<n; i++)
    {
        cin>>num;
        if(num == 0)
        {
            cin>>x;
            ment[i] = x;
        }
        else
        {
            for(int j=0; j<num; j++)
            {
                cin>>x;
                node[i].child.push_back(x);
            }
        }
    }
    queue<int>q;
    q.push(root);
    node[root].layer = 0;
    double ans = 0;
    double sum = 1;
    double p = 1+rate;
 //   cout<<"P="<<p<<endl;
    while(!q.empty())
    {
        int now = q.front();
        q.pop();
        int len = node[now].child.size();
        for(int i=0; i<len; i++)
        {
            node[node[now].child[i]].layer = node[now].layer + 1;
            q.push(node[now].child[i]);
        }
    }
    for(int i=0; i<n; i++)
    {
        if(ment[i] != 0)
        {
            int lay = node[i].layer;
            sum = pow(p,lay);
            sum = sum*ment[i];
            ans+=sum;
            sum = 1;
        }
    }
    printf("%.1f\n",ans*price);
}

猜你喜欢

转载自blog.csdn.net/qq_38851184/article/details/81278885