1079 Total Sales of Supply Chain(DFS)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] … ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

题目大意

一棵树由根结点(根经销商)开始,每下降一层,商品价格就会增加r%,只有叶子结点(零售商)能将商品卖给顾客。现给出根经销商的商品价格p,以及叶子结点(零售商)的商品数量,求商品所能卖出的总价格。

思路

设置vector存储每个结点的孩子,数组data存储叶子结点的商品数量。用DFS的方法,设当前层价格为p,每下降一层,更新p为p*(1+r%),下降至叶子结点时,更新总价格res并返回。

AC代码

#include <cstdio>
#include <iostream>
#include <vector> 
using namespace std;

const int maxn = 100010;
vector<int> G[maxn]; //存放孩子结点
int data[maxn] = {0}; //存放叶子结点产品数量
int n, k, id;
double p, r; //单价 价格增量
double res = 0.0;

void DFS(int x, double p){
	//x为当前访问结点,p为当前价格 
	if(data[x] != 0){ //叶子结点
		res += data[x] * p;
		return;
	}
	else{
		for(int i = 0; i < G[x].size(); i++)
			DFS(G[x][i], p * (1 + r / 100.0));
	}
}

int main(){ 
	
	scanf("%d%lf%lf", &n, &p, &r);
	for(int i = 0; i < n; i++){
		scanf("%d", &k);
		if(k == 0){
			scanf("%d", &data[i]);
		}
		else{
			for(int j = 0; j < k; j++){
				scanf("%d", &id);
				G[i].push_back(id);
			}
		}
	}
	DFS(0, p);
	printf("%.1lf", res);
	return 0;
}
发布了110 篇原创文章 · 获赞 0 · 访问量 1276

猜你喜欢

转载自blog.csdn.net/qq_43072010/article/details/105327872