E - Alignment POJ - 1836

E - Alignment

 POJ - 1836 

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

题意:已知一条队伍每个人的,要求每个人至少可以看到这条队伍的最左边或最右边的一边(只能看到比自己矮的)。

思路:主要保持从前面往后面是递增的,从后面往前面是递增的即可,即至多有一个极值。

#include<cstdio>
#include<stack>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N=1100;
const int nmax = 50010;
const double esp = 1e-8;
const double PI=3.1415926;
double a[N];
int lr[N],rl[N];
int main()
{
  int n;
  scanf("%d",&n);
  for(int i=0;i<n;i++){
      scanf("%lf",&a[i]);
  }
  for(int i=0;i<n;i++){  //从前往后求包含a[i]在内的最长的递增序列
      lr[i]=1;
      for(int j=0;j<i;j++){
            if(a[j]<a[i]){
                  lr[i]=max(lr[i],lr[j]+1);
            }
      }
  }
  for(int i=n-1;i>=0;i--){//从后往前求包含a[i]在内的最长的递增序列
      rl[i]=1;
      for(int j=n-1;j>i;j--){
            if(a[i]>a[j])
                  rl[i]=max(rl[j]+1,rl[i]);
      }
  }
  int maxl=0;
  for(int i=0;i<n;i++){  //从前或从后往中间递增的最长长度
      for(int j=i+1;j<n;j++){
            maxl=max(maxl,lr[i]+rl[j]);
      }
  }
  printf("%d\n",n-maxl);
  return 0;
}

猜你喜欢

转载自blog.csdn.net/clz16251102113/article/details/83064593