E - Is It A Tree? POJ - 1308

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

题意:

给出你每对点的链接情况,问你最后构成的是不是一棵树。

扫描二维码关注公众号,回复: 2669471 查看本文章

解析:

并查集。有以下几点需要判断。 
1. 空树是一棵树 
2. 自环不算树 
3. 森林不算树 
4. 构成环路的不算树

题解:和b题是一样的题型,就是输出需要改一下。

#include<stdio.h>
int set[110000];
int book[110000];
int findx(int x)
{
    int r=x;
    while(set[r]!=r)
        r=set[r];
    return r;
}
bool memge(int x,int y)
{
    int fx,fy;
    fx=findx(x);
    fy=findx(y);
    if(fx!=fy)
    {
        set[fx]=fy;
        return 1;
    }
    else
        return 0;
}
int main()
{
    int a,b,i,flag,cnt,k=0;
    int min,max;
    while(~scanf("%d%d",&a,&b))
    {
        k++;
        if(a==-1&&b==-1)
            break;
        flag=1;
        cnt=0;
        if(a==0&&b==0)
        {
            printf("Case %d is a tree.\n",k);
            continue;
        }
        for(i=0; i<100010; i++)
        {
            set[i]=i;
            book[i]=0;
        }
        min=99999999;
        max=-1;
        while(a||b)
        {
            if(a>max)
                max=a;
            if(b>max)
                max=b;
            if(a<min)
                min=a;
            if(b<min)
                min=b;
            book[a]=1;
            book[b]=1;
            if(memge(a,b)==0)
                flag=0;
            scanf("%d%d",&a,&b);
        }
        if(flag==0)
            printf("Case %d is not a tree.\n",k);
        else
        {
            for(i=min; i<=max; i++)
            {
                if(book[i]&&set[i]==i)
                    cnt++;
            }
            if(cnt==1)
                printf("Case %d is a tree.\n",k);
            else
                printf("Case %d is not a tree.\n",k);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lihuanz/article/details/81541194