C - Alignment

题目:

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

题意:

令原队列的最少士兵出列后,使得新队列任意一个士兵都能看到左边或者右边的无穷远处。就是使新队列呈三角形分布就对了。

思路:

即左边的递增序列人数和右边的递减序列人数之和最大因而可转化为求“最长不降子序列”和“最长不升子序列”问题。进一步转化为从头部求出最长不下降子序列与从尾部求出最长不下降子序列即可,分别求出二者的大小,最后用队列长度减去二者之和就是我们所求的出列的士兵个数。

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int n;
double a[1001];
int d[1001],p[1001];

int main()
{
    while(~scanf("%d",&n))
    {
        int i,j;
        for(i=0; i<n; i++)
        {
            scanf("%lf",&a[i]);
        }
        memset(d,0,sizeof d);
        memset(p,0,sizeof p);
        for(i=0; i<n; i++)
        {
            d[i]=1;
            for(j=0; j<i; j++)
            {
                if(a[i]>a[j]&&d[i]<=d[j])
                    d[i]=d[j]+1;
            }
        }
        for(i=n-1; i>=0; i--)
        {
            p[i]=1;
            for(j=n-1; j>=i; j--)
            {
                if(a[i]>a[j]&&p[i]<=p[j])
                    p[i]=p[j]+1;
            }
        }
      /* for(i=0; i<n; i++)
            printf("%d ",d[i]);
        printf("\n");
        for(i=0; i<n; i++)
            printf("%d ",p[i]);
        printf("\n");*/
        int max=-99999999;
        for(i=0; i<n; i++)
        {
            for(j=i+1; j<n; j++)
            {
                if(d[i]+p[j]>max)
                    max=d[i]+p[j];
            }
        }
        //printf("max==%d\n",max);
        printf("%d\n",n-max);
    }
    return 0;
}
/*

1 1 1 2 2 1 3 4
3 3 2 3 2 1 1 1

*/

猜你喜欢

转载自blog.csdn.net/titi2018815/article/details/81367536