POJ3278 Catch the cow BFS广搜

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Hacker_Wind/article/details/79940320

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

刚开始看到题想用DFS搜索,但判断边界条件较复杂,故改用BFS。注意在check函数中的vis数组越界问题会导致RuntimeError

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include <queue>
using namespace std;
//ios::sync_with_stdio(false);
//typedef long long ll;
const int MAXN = 100005;
//const int inf = 0x3f3f3f3f;

int step[100005];
int vis[100005];
queue<int> q;
bool check(int a)
{
    if(a<0||a>100000||vis[a]==1)//先判断a<0,如果a<0的话,则vis[a]越界,runtime error
        return 0;
    else
        return 1;
}
int bfs(int n,int k)
{
    int now,next;
    q.push(n);
    step[n]=0;
    vis[n]=1;
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        for(int i=0; i<3; i++)
        {
            if(i==0)
                next=now-1;
            else if(i==1)
                next=now+1;
            else
                next=now*2;
            if(check(next))
            {
                q.push(next);
                vis[next]=1;
                step[next]=step[now]+1;
            }
            if(next==k)
                return step[next];
        }

    }
}
int main()
{ 
    //ios::sync_with_stdio(false);
    int n,k;
    cin>>n>>k;
    memset(vis,0,sizeof(vis));
    memset(step,0,sizeof(step));
    //while(!q.empty()) q.pop();
    if(n>=k)
        cout<<n-k<<endl;
    else
    {
        int a=bfs(n,k);
        cout<<a<<endl;
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/Hacker_Wind/article/details/79940320
今日推荐