POJ1426 Find The Multiple题意及题解

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Hacker_Wind/article/details/79948875
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

题意为找到一个大于等于n的倍数m,且m只由0和1组成。暴力会超时,所以从1开始直接列举所有的二进制表示。用bfs分两种情况,一种是当前数乘10,另一种是当前数乘10加1,因为n最大为200,故列举二进制不会超时。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
using namespace std;
void bfs(int n)
{
    queue<long long> q;//q的数会比较大,所以用long long
    while(!q.empty())
        q.pop();
    q.push(1);
    while(1)
    {
        long long now=q.front();
        if(now%n==0)
        {
            cout<<now<<endl;
            return ;
        }
        q.pop();
        q.push(now*10);
        q.push(now*10+1);
    }
}
int main()
{
    int n;
    while(cin>>n&&n)
    {
        bfs(n);
    }
    return 0;
}




猜你喜欢

转载自blog.csdn.net/Hacker_Wind/article/details/79948875