POJ1426 Find The Multiple【BFS】

Find The Multiple

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 42543   Accepted: 17897   Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

Dhaka 2002

问题链接:POJ1426 Find The Multiple

题解:https://blog.csdn.net/lyy289065406/article/details/6647917

AC的C++代码:

#include<iostream>

using namespace std;
const int N=524286;
int mod[N];

int main()
{
	int n,i,k;
	while(~scanf("%d",&n)&&n){
		mod[1]=1%n;//初始化,n倍数的最高位必是1
		for(i=2;mod[i-1];i++)
		  mod[i]=(mod[i/2]*10+i%2)%n;
		i--;
		k=0;
		while(i){
			mod[k++]=i%2;
			i/=2;
		} 
		while(k)
		  printf("%d",mod[--k]);
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/82872904