Find The Multiple(POJ-1426)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u011815404/article/details/84073671

Problem Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

——————————————————————————————————————————————————————

题意:给出一个数 n ,要求输出一个二进制串,要求该串能整除 n

思路:bfs 搜索,不断取队首元素,判断能否整除,若能直接输出,若不能则让 当前元素*10 与 当前元素*10+1 存入队列,不断判断,直到有解为止。

Source Program

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define PI acos(-1.0)
#define E 1e-6
#define MOD 16007
#define INF 0x3f3f3f3f
#define N 10001
#define LL long long
using namespace std;
int n;
int main(){
    while(scanf("%d",&n)!=EOF&&n){
        queue<LL> Q;
        Q.push(1);
        while(!Q.empty()){
            LL temp=Q.front();
            Q.pop();
            if(temp%n==0){
                printf("%lld\n",temp);
                break;
            }

            Q.push(temp*10);
            Q.push(temp*10+1);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u011815404/article/details/84073671