POJ1426 Find The Multiple(BFS)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/UncleJokerly/article/details/83445588

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

题意:
给出一个数n,找出任意一个数m,m是n的倍数且只有0与1组成。

解题思路:

BFS。从1开始,依次添0和1,即

1

10 11

100 101 110 111

......

只要找到一个满足条件的m即可结束搜索。

AC代码:
 

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

queue<long long> q;

void bfs(int n)
{
	while(!q.empty())
	{
		q.pop();
	}
	q.push(1);
	while(!q.empty())
	{
		if(q.front()%n==0)
		{
			printf("%lld\n",q.front());
			return;
		}
		q.push(q.front()*10);
		q.push(q.front()*10+1);
		q.pop();
	}
}

int main()
{
	int n;
	while(~scanf("%d",&n)&&n)
	{
		bfs(n);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/UncleJokerly/article/details/83445588