HDU ACM 1.2.1 Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7474 Accepted Submission(s): 3673
 
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 
Output
Print the total time on a single line for each test case. 
 
Sample Input
1 2
3 2 3 1
0
 
Sample Output
17
41
 
Author
ZHENG, Jianqiang
 


代码:

#include <iostream>


using namespace std;


void main()
{
int N;
cin >> N;

while (N != 0)
{
int totalsec = 0;
int currentFloor = 0;
int targetFloor = 0;
for (int i = 0; i < N;i++)
{
cin >> targetFloor;
//cout << currentFloor << " " << targetFloor << endl;


if (targetFloor > currentFloor)
totalsec += (targetFloor - currentFloor) * 6 + 5;
else if (targetFloor < currentFloor)
totalsec += (currentFloor - targetFloor ) * 4 + 5;
else
totalsec += 5;//防坑
//cout << totalsec << endl;
currentFloor = targetFloor;
}

cout << totalsec << endl;


cin >> N;
}
}

猜你喜欢

转载自blog.csdn.net/qq_39459939/article/details/78912956