HDU1008Elevator

题目描述:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

思路:

水题一个,nextpost记录下一个要去的位置,lastpost记录上一个要去的位置。

  1. nextpost大于lastpost时,相减乘6
  2. nextpost大于lastpost时,相减乘4
  3. 每输入一个,sum必加5

代码如下

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<stdlib.h>
#define MAXN 101
using namespace std;
int main()
{
    int N, i, nextpost, lastpost,sum;
    while (cin >> N&& N) {
        lastpost = 0;
        sum = 0;
        for (i = 0; i < N; i++) {
            cin >> nextpost;
            if (nextpost < lastpost)
                sum = sum + (lastpost - nextpost) * 4;
            else {
                sum = sum + (nextpost - lastpost) * 6;
            }
            lastpost = nextpost;
            sum = sum + 5;
        }
        cout << sum << endl;

    }
    return 0;
}
//水题一个

猜你喜欢

转载自blog.csdn.net/m0_37051465/article/details/78606691