POJ1797 Heavy Transportation【并查集+贪心】

Heavy Transportation

Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 50413   Accepted: 13007

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

Source

TUD Programming Contest 2004, Darmstadt, Germany

问题链接:POJ1797 Heavy Transportation

问题描述:给定n个交叉点(从1开始编号)有m个双向的街道链接它们,每条街道都有一个最大负重,问从1号结点到n号结点的路线方案中,最小负重街道的最大值为多少。

解题思路:并查集+贪心,按照边的最大负重从大到小加边,直到使得1号结点和n号结点连通

AC的C++程序:

#include<iostream>
#include<algorithm>
#include<cmath>

using namespace std;

const int N=1005;

int pre[N];

//初始化函数 :使各个结点是自己的父节点 
void init(int n)
{
	for(int i=1;i<=n;i++)
	  pre[i]=i;
} 

int find(int x)
{
	int r=x;
	while(r!=pre[r])
	  r=pre[r];
	//路径压缩
	while(x!=r){
		int i=pre[x];
		pre[x]=r;
		x=i;
	}
	return r; 
}

struct Edge{
	int u,v,c;
	bool operator<(const Edge &a)const
	{
		return c>a.c;
	}
}e[N*N/2];

void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	  pre[fx]=fy;
} 

int main()
{
	int T,n,m;
	scanf("%d",&T);
	for(int t=1;t<=T;t++){
		scanf("%d%d",&n,&m);
		for(int i=0;i<m;i++)
		  scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].c);
		sort(e,e+m);
		init(n);
		//从大到小加边 
		for(int i=0;i<m;i++){
			join(e[i].u,e[i].v);//添加边d[i]
			if(find(1)==find(n)){//添加边d[i]后1号结点和2号结点连通了,这就是答案
			  printf("Scenario #%d:\n%d\n\n",t,e[i].c); 
			  break;
			}
		} 
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/83110845