Heavy Transportation POJ - 1797 最短路(dij)

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

这题类似与poj2253 之前写了有 自己去翻把

从1->n任意一条路 想要路面不压垮。车的最大重量必须是这条路每个边的权值最小在所有路的这个最小权值要最大

如果你们闲得蛋疼可以考虑一下用priority queue优化 毕竟直接跑要1500ms 很吓人 虽然poj给了3000ms 有时间会写一下优化代码

#include<iostream>
#include<cstring>
#include<cmath>
#define clr(a,b) memset(a,b,sizeof(a));
#define inf 0x3f3f3f3f
using namespace std;
int map[1005][1005],dis[1005];
int n,m,t,visit[1005];

void dijstra()
{
	clr(visit,0)
	for(int i=1;i<=n;i++)
	{
		dis[i]=map[1][i];
	} 
	for(int i=1;i<=n;i++)
	{
		int minn=0,s;
		for(int j=1;j<=n;j++)
		{
			if(dis[j]>minn&&!visit[j])
			{
				minn=dis[j];
				s=j;
			}
		}
		visit[s]=1;
		for(int j=1;j<=n;j++)
		{			
			dis[j]=max(dis[j],min(dis[s],map[s][j]));//这个就是 0->s==dis[s]	s->j==map[s][j]为了到达j,车必须轻于这两段路的最小值 这个最小值要在所有路中最大 
		}
	}
}

int main()
{
	ios::sync_with_stdio(false);
	int cnt=0;
	cin>>t;
	while(t--)
	{		
		cin>>n>>m;	
		clr(map,0)
		for(int i=1;i<=m;i++)
		{
			int s,e,p;
			cin>>s>>e>>p;
			if(0<p)
			map[s][e]=map[e][s]=p;
		}
		dijstra();
		//if(cnt)	printf("\n");
		printf("Scenario #%d:\n",++cnt);
		printf("%d\n\n",dis[n]);		
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41544329/article/details/82535048