【POJ1797】 Heavy Transportation(最短路DIJ变种)

Heavy Transportation

Time Limit: 3000msMemory Limit: 30000KB 64-bit integer IO format: %lld Java class name: Main

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题目的意思是输入点数和边数,然后每两个点之间都是一座桥连接的,所以接下来输入两个点和他们之间桥的最大承重量。

我们的目的就是找到一条1到N的路,并使得可以在这条路上运输的最大承重量是所有路线中最大的。输出这个承重量。

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

using namespace std;

const int maxn = 1e3+5;
const int INF = 9999999;

int map[maxn][maxn];
int dis[maxn];
int vis[maxn];
int T;
int n,m;
int a,b,time;

int min(int a,int b){
    return a<b ? a:b;
}

void dij(){
    memset(vis,0,sizeof(vis));
    for(int i=1 ; i<=n ; i++){
        dis[i]=map[1][i];
    }
    for( int i=1 ; i<=n ; i++ ){
        int u;
        int f=-1;
        for( int j=1 ; j<=n ; j++ ){
            if(!vis[j]&&(u==-1||dis[j]>f)){
                f=dis[j];
                u=j;
            }
        }
        vis[u]=1;
        for( int j=1 ; j<=n ; j++ ){
            if(!vis[j]&&dis[j]<min(map[u][j],dis[u])){
                dis[j]=min(map[u][j],dis[u]);
            }
        }
    }
}

int main(){
    scanf("%d",&T);
    int k=1;
    while(T--){

        memset(map,0,sizeof(map));
        scanf("%d%d",&n,&m);
        for(int i=1 ; i<=m ; i++){
            scanf("%d%d%d",&a,&b,&time);
                map[a][b]=map[b][a]=time;
        }
        dij();
        cout<<"Scenario #"<<k++<<":"<<endl;
        cout<<dis[n]<<endl;
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/thesprit/article/details/51996361