Heavy Transportation POJ - 1797 SPFA 最短路

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:

4

求1到n点的所有通路中最小值的最大情况。用SPFA,改变一下判断条件。

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<queue>
#include<string.h>
#define inf 0x3f3f3f3f 
using namespace std;
const int maxn=1005;
int n,m,t,tot;
int head[maxn],dis[maxn];
bool vis[maxn];
struct node
{
	int to;
	int w;
	int next;
}e[maxn*maxn];

void init()
{
	memset(head,-1,sizeof(head));
	memset(vis,false,sizeof(vis));
	memset(dis,0,sizeof(dis));
	tot=0;
	return ;
}
void addedge(int u,int v,int w)
{
	e[tot].to=v;
	e[tot].w=w;
	e[tot].next=head[u];
	head[u]=tot++;
	return ;
}
void spfa(int st)
{
	queue<int>q;
	int v,w;
	vis[st]=true;
	dis[st]=inf;
	q.push(st);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=false;
		for(int i=head[u];i!=-1;i=e[i].next)
		{
			v=e[i].to;
			w=e[i].w;
			if(min(dis[u],w)>dis[v])
			{
				dis[v]=min(dis[u],w);
				if(!vis[v])
				{
					q.push(v);
					vis[v]=true;
				}
			}
			
		}
	}
}
int main() 
{
	//freopen("C:/input.txt", "r", stdin);
	scanf("%d",&t);
	for(int i=1;i<=t;i++)
	{
		init();
		scanf("%d%d",&n,&m);
		for(int i=0;i<m;i++)
		{
			int u,v,w;
			scanf("%d%d%d",&u,&v,&w);
			addedge(u,v,w);
			addedge(v,u,w);
		}
		spfa(1);
		printf("Scenario #%d:\n",i);
		printf("%d\n",dis[n]);
		if(i!=t)
		{
			printf("\n");
		}
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/evildoer_llc/article/details/80345019