POJ1797 - Heavy Transportation(最短路)

Heavy Transportation POJ - 1797 

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 
Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4

题意:给了N个点和M条边,求每条路径中最大边的最小值。
 
 
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstring>
#define inf -1
using namespace std;
int a[1005][1005], vis[1005] = {0}, book[1005] = {0};
int main()
{
    std::ios::sync_with_stdio(0);
    int n, i, m, j, k, t, q, x;
    while(cin >> t)
    {
        for(k = 1; k <= t; k++)
        {
            cin >> n >> m;
            memset(vis, 0 , sizeof(vis));
            memset(book, 0, sizeof(book));
            for(i = 1; i <= n; i++)
            {
                for(j = 1; j <= n; j++)
                {
                    if(i != j)a[i][j] = inf;
                }
            }
            for(q = 1; q <= m; q++)
            {
                cin >> i >> j >> x;
                a[i][j] = x;
                a[j][i] = x;
            }
            for(i = 1; i <= n; i++)vis[i] = a[1][i];
            book[1] = 1;
            for(i = 1; i <= n - 1; i++)
            {
                int maxn = 0, u;
                for(j = 1; j <= n; j++)
                {
                    if(book[j] == 0 && vis[j] > maxn)
                    {
                        maxn = vis[j];
                        u = j;
                    }
                }
                book[u] = 1;
                for(j = 1; j <= n; j++)
                {
                    vis[j] = max(vis[j], min(vis[u], a[u][j]));
                }
            }
            printf("Scenario #%d:\n%d\n\n", k, vis[n]);
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_16530503/article/details/80481501