HDU 1011 Starship Troopers(树形dp,树形背包)

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible. 

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before. 

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer. 

Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern. 

The last test case is followed by two -1's. 

Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms. 

Sample Input

5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1

Sample Output

50
7

在n个洞中(树结构),每个洞有a个"bugs"和b的价值。你有m个士兵,从1号房间开始攻打,一个士兵可以打最多20个"bugs",如果要拿到某个洞的价值,需留下k个士兵消灭这个洞的所有"bugs",问你花费这m个士兵可以得到的最大价值是多少?

树形背包 dp[p][j]=max(dp[p][j],dp[p][j-k]+dp[ son[p] ][ k ]);

dp[i][j]代表i为根节点士兵数为j时的最大可能,注意小于20个也需要士兵

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#define inf 0x3f3f3f3f
using namespace std;
#define maxn 220
int n,m;
int dp[maxn][maxn];
vector<int>son[maxn];
int vis[maxn];
int bug[maxn],p[maxn];
void dfs(int x)
{vis[x]=1;
    int cost=(bug[x]+19)/20;
    for(int i=cost;i<=m;i++)
    dp[x][i]=p[x];
    for(int i=0;i<son[x].size();i++)
    {
        int v=son[x][i];
        if(vis[v]==1)
        continue;
        dfs(v);
        for(int j=m;j>=cost;j--)
        for(int k=1;k<=j-cost;k++)
        dp[x][j]=max(dp[x][j],dp[x][j-k]+dp[v][k]);
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {if(n==-1&&m==-1)
    break;
    memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {scanf("%d%d",&bug[i],&p[i]);
        son[i].clear();
        vis[i]=0;
    }
    int x,y;
    for(int i=0;i<n-1;i++)
    {scanf("%d%d",&x,&y);
    son[x].push_back(y);
    son[y].push_back(x);

    }
    if(m==0)
    {printf("0\n");
    continue;
    }
    dfs(1);
    printf("%d\n",dp[1][m]);
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/82960416