hdu 1011 Starship Troopers【树形dp】

Problem Description

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

 

Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.

 

Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

 

Sample Input

 

5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1

扫描二维码关注公众号,回复: 3032538 查看本文章
 

Sample Output

 

50 7

题意:

有n个洞穴编号为1~n,洞穴间有通道,形成了一个n-1条边的树, 洞穴的入口即根节点是1。
每个洞穴有x个敌人,并有价值y的价值,全部消灭完一个洞穴的虫子,就可以获得这个洞穴的y个金子.
现在要派m个战士去找金子,从入口进入。每次只有消灭完当前洞穴的所有虫子,才可以选择进入下一个洞穴。
如果要获得某个洞穴的价值,必须留下足够杀死所有敌人的战士数量, 即(x+19)/20个战士,然后这些留下战士就不能再去其它洞穴
其他战士可以继续走去其它洞穴,可以选择分组去不同的洞穴。战士只能往洞穴深处走,不能走回头路
问最多能获得多少价值?

分析:

树形dp

如果要获得某个洞穴的价值,必须留下足够杀死所有敌人的战士数量,需要留下j-k=num[u],其余的给儿子                                    dp[u][j] = max(dp[u][j], dp[u][j-k] + dp[v][k]);

代码:

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#define MAXN 100+10
using namespace std;
vector<int> G[MAXN];
int dp[MAXN][MAXN]; ///dp[i][j]表示在洞穴i时 用j个战士 获得的最大价值
int val[MAXN];      ///洞穴可获得的最大价值
int num[MAXN];      ///记录每个洞穴 消耗的士兵数目
int N, M;
void DFS(int u, int fa)
{
    for(int i = num[u]; i <= M; i++)///预处理,要留num[i]的人在洞穴u
        dp[u][i] = val[u];
    for(int i = 0; i < G[u].size(); i++)
    {
        int v = G[u][i];
        if(v == fa) continue;
        DFS(v, u);
        for(int j = M; j >= num[u]; j--)
        {
            for(int k = 1; k + num[u] <= j; k++)///枚举 到v房间时 可能需要的士兵
            {
                dp[u][j] = max(dp[u][j], dp[u][j-k] + dp[v][k]);
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d", &N, &M)&&(N!=-1||M!=-1))
    {
        int a, b;
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= N; i++)
        {
            G[i].clear();
            scanf("%d%d", &num[i], &val[i]);
            num[i]=(num[i]+19)/20;
        }
        for(int i = 1; i < N; i++)
        {
            scanf("%d%d", &a, &b);
            G[a].push_back(b);
            G[b].push_back(a);
        }
        if(M == 0)///特判
        {
            printf("0\n");
            continue;
        }
        DFS(1, -1);
        printf("%d\n", dp[1][M]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lml11111/article/details/81986542