hdu 1520 (树形dp)

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output
Output should contain the maximal sum of guests’ ratings.

Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output
5

上司和直系下属不能同时出现,求能获得的最大价值

#ifdef WSM
#include <bits:stdc++.h>
#else
#include <bits/stdc++.h>
#endif
#define mem(a) memset(a,0,sizeof(a));
using namespace std;
typedef long long ll;
const int N=6e3+7;
int f[N][2],in[N];
vector<int> q[N];
void dfs(int x)
{
    for(int i=0;i<q[x].size();i++)
    {
        int d=q[x][i];
        dfs(d);
        f[x][1]+=f[d][0];//如果x来的话,那么一定是从他的直系下属不来的情况转移
        f[x][0]+=max(f[d][1],f[d][0]);//如果x不来,那么就是他的直系下属来或者不来的最大值转移(针对每个下属来或不来单独考虑,所以+=)
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<=n;i++)
            q[i].clear();
        mem(f);
        mem(in);
        for(int i=1;i<=n;i++)
            scanf("%d",&f[i][1]);//边缘初始化(每个节点的权值)
        int l,k;
        while(scanf("%d%d",&l,&k)&&l&&k)
        {
            q[k].push_back(l);//记录k的所以子节点
            in[l]++;//记录是否为根节点
        }
        for(int i=1;i<=n;i++)
        {
            if(!in[i])//in[i]为0,则i必为根节点
            {
                dfs(i);
                printf("%d\n",max(f[i][0],f[i][1]));//输出最大的价值
                break;
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/oinei/article/details/78152838