POJ 2253Frogger floyd算法改进

Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 55120   Accepted: 17371

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

两个人分别在编号为1和2的石头上,求两者之前最少的青蛙距离。

题目中青蛙距离的定义:一段距离中的最短跳跃长度。

比如一段距离有4块石头,他们之间距离分别为3,5,1,4。那么该段的青蛙距离就是5,因为如果跳跃长度小于5的时候会落入池塘。

有人博客说是求最短路径中的最长间距,但是我个人是不认可的,因为我觉得和最短路径没什么关系(或许可能是我理解不到位),虽然两种理解都能过。

一下是AC代码

#include<iomanip>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int main()
{
    int num,casr=0;
    while(cin>>num&&num)
    {
        double x[num+1],y[num+1];
        double dis[num+1][num+1];
        memset(x,0,sizeof(x));
        memset(y,0,sizeof(y));
        memset(dis,0,sizeof(dis));
        for(int i=1; i<=num; i++)
            cin>>x[i]>>y[i];
        for(int i=1; i<=num; i++)
            for(int j=1; j<=num; j++)
                dis[i][j]=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));///dis为两块石头的距离
        for(int k=1;k<=num;k++)    
            for(int i=1;i<=num;i++)    
                for(int j=1;j<=num;j++)
                    if(dis[i][j]>dis[i][k]&&dis[i][j]>dis[k][j])///如果可以通过编号为k的石头中转,那么只有两者的距离都比dis【i】【j】小的时候才会更新
                        dis[i][j]=dis[j][i]=max(dis[i][k],dis[k][j]);
        cout<<"Scenario #"<<++casr<<endl;
        printf("Frog Distance = %.3f\n",dis[1][2]);///两人分别在编号为1和2的石头上
        cout<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41548233/article/details/80084106
今日推荐