How Many Answers Are Wrong (种类并查集)

 How Many Answers Are Wrong

TT and FF are ... friends. Uh... very very good friends -________-b 

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored). 


Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers. 

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose. 

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence. 

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed. 

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers. 

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy) 

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions. 

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N. 

You can assume that any sum of subsequence is fit in 32-bit integer. 

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1

题意:N个小区间连续组成一个大区间,给出M个条件,Ai, Bi , Si,表示区间Ai到Bi(包括)的长度为Si(Si可以为负数),问满足前面正确的条件的情况下,错误的条件的个数。(错误的条件对后面的条件没有影响)

题解:种类并查集,root[i]记录i的父亲节点,根据Find函数更新;rela[i]记录i到根节点的区间长度,根据Union函数更新,并判断是否满足条件。具体看注释。

最后附上AC代码

//#include<bits/stdc++.h>
//#include <unordered_map>
//#include<unordered_set>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<set>
#include<climits>
#include<queue>
#include<cmath>
#include<stack>
#include<map>
using namespace std;
#define LL long long
#define ULL unsigned long long
#define MT(a,b) memset(a,b,sizeof(a))
const int INF  =  0x3f3f3f3f;
const int O    =  1e5;
const int mod  =  1e9+7;
const int maxn =  2e5+5;
const double PI  =  3.141592653589;
const double E   =  2.718281828459;

int root[maxn], rela[maxn];
int ans = 0;

int Find(int x){
    if(root[x] == x) return x;
    int t = Find(root[x]);
    rela[x] = rela[root[x]] + rela[x];//更新长度
    root[x] = t;//更新父亲节点
    return t;
}

void Union(int a, int b, int c){
    int x = Find(a);
    int y = Find(b);  //查找根节点
    if(x == y) {  //如果相等,判断是否满足条件
        if(rela[a] - rela[b] != c) ans ++;
    }
    else if(x < y){
        root[x] = y;
        rela[x] = rela[b] - rela[a] + c;
    }
    else {
        root[y] = x;
        rela[y] = rela[a] - rela[b] - c;
    }
    //关于x大于或者小于y可以根据自己画图理解一下
}

int main()
{
    int n ,k;
    while(scanf("%d%d", &n, &k)!=EOF){//单组输入要错
        ans = 0;
        for(int i=0; i<=n; i++){// 初试化
            root[i] = i;
            rela[i] = 0;
        }
        while(k--){
            int u, v, c; scanf("%d%d%d", &u, &v, &c);
            Union(u-1, v, c);
        }
        printf("%d\n", ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Mannix_Y/article/details/82820149