How Many Answers Are Wrong (彻底理解带权并查集)

TT and FF are ... friends. Uh... very very good friends -________-b 

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored). 


Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers. 

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose. 

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence. 

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed. 

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers. 

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy) 

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions. 

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N. 

You can assume that any sum of subsequence is fit in 32-bit integer. 

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1

"子曰:由,诲汝知之乎!知之为知之,不知为不知,是知也"

之前看题解写过一遍 当再次出现的时候还是不会 感到羞愧

这次进行了原理的彻底理解

(已经完全搞懂了

实质上并查集只是一种工具 来判断两个数之前是否有关联

代码写上注释作为模板

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<iostream>
using namespace std;
int sum[200005];//记录i到根节点之间和的差值,若再跟节点右侧 则为负数
int father[200005];
int fi(int x)
{
    if(father[x]==x) return x;
    else
    {
        int pos=father[x];//记录父节点 方便递归更新
        father[x]=fi(father[x]);
        sum[x]+=sum[pos];//路径压缩时 维护到跟的和
    }
    return father[x];
}
int main()
{
    int n,m;
    int tmp1,tmp2,tmp3;
    int fa1,fa2;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0; i<=n; i++)
        {
            father[i]=i;
            sum[i]=0;
        }
        int ans=0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&tmp1,&tmp2,&tmp3);
            tmp1--;
            int root1=fi(tmp1);
            int root2=fi(tmp2);
            if(root1!=root2)
            {
                sum[root1]=tmp3+sum[tmp2]-sum[tmp1];
                father[root1]=root2;
            }//不为同1集合 进行合并
            else
            {
                if(tmp3!=sum[tmp1]-sum[tmp2]) ans++;
                //为同一集合直接判断
            }
        }
        printf("%d\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/caowenbo2311694605/article/details/88182123
今日推荐