HDU3038 How Many Answers Are Wrong【加权并查集】

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12605    Accepted Submission(s): 4496


Problem Description
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
 

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
 

Output
A single line with a integer denotes how many answers are wrong.
 

Sample Input
 
  
10 51 10 1007 10 281 3 324 6 416 6 1
 

Sample Output
 
  
1
 

Source

问题链接HDU3038 How Many Answers Are Wrong

问题简述:(略)

问题分析

  这是一个并查集问题,但是需要做一些特殊处理,算一下距离。

  先占个位置,不解释。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* HDU3038 How Many Answers Are Wrong */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 200000;
int f[N + 1];
int dist[N + 1];
int ans;

void UFInit(int n)
{
    for(int i = 0; i <= n; i++)
        f[i] = i;
    memset(dist, 0, sizeof(dist));
}

int Find(int a) {
    if(a == f[a])
        return a;
    else {
        int pa = f[a];
        f[a] = Find(f[a]);
        dist[a] += dist[pa];
        return f[a];
    }
}

void Union(int a, int b, int s)
{
    int pa = Find(a);
    int pb = Find(b);
    if (pa == pb) {
        if(dist[a] - dist[b] + s != 0)
            ans++;
    } else {
        f[pb] = pa;
        dist[pb] = dist[a] - dist[b] + s;
    }
}

int main()
{
    int n, m;
    while(~scanf("%d%d", &n, &m)) {
        UFInit(n);

        ans = 0;
        for(int i = 1; i <= m; i++) {
            int a, b, s;
            scanf("%d%d%d", &a, &b, &s);
            Union(a, b + 1, s);
        }

        printf("%d\n", ans);
    }

    return 0;
}






猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80221492