bfs打印路径POJ3984

迷宫问题

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu

Description
定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output
左上角到右下角的最短路径,格式如样例所示。

Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
int map[5][5];
int dx[4]={1,-1,0,0};
int dy[4]={0,0,-1,1};
int front=0,rear=1;
struct node
{
    int x,y,pre;
}q[100];
void print(int i)
{
    if(q[i].pre!=-1)
    {
        print(q[i].pre);
        cout<<'('<<q[i].x<<", "<<q[i].y<<')'<<endl;
    }
}
void bfs(int x1,int y1)
{
    q[front].x=x1;
    q[front].y=y1;
    q[front].pre=-1;
    while(front<rear)
    {
        for(int i=0;i<4;i++)
        {
            int nx=dx[i]+q[front].x;
            int ny=dy[i]+q[front].y;
            if(nx>=0&&nx<5&&ny>=0&&ny<5&&map[nx][ny]!=1)
            {
                map[nx][ny]=1;
                q[rear].x=nx;
                q[rear].y=ny;
                q[rear].pre=front;
                rear++;
            }
            if(nx==4&&ny==4) print(front);

        }
        front++;
    }
}
int main()
{
    for(int i=0;i<5;i++)
    {
        for(int j=0;j<5;j++)
        {
            cin>>map[i][j];
        }
    }
    cout<<"(0, 0)"<<endl;
    bfs(0,0);
    cout<<"(4, 4)"<<endl;
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_42825221/article/details/82824140